安装node sass失败常见解决方案

背景

一般来说安装`node-sass`都是失败,因为这个依赖比较苛刻。原因如下:

1. 每个开发人员用的node版本不一样,而`node-sass`的每个版本对node有要求。

2. 网络问题(国内网络访问外网不通)。

解决方案

网络问题

首先尝试使用npm国内源,有3种方法:

1. 修改 `.npmrc` 文件(Windows下路径是`C:\Users\Administrator\.npmrc`,linux/macOS下路径是`~\.npmrc`),新增:`SASS_BINARY_SITE=
http://npm.taobao.org/mirrors/node-sass`,最终内容如下:

“`config

registry=https://repo.huaweicloud.com/repository/npm/

SASS_BINARY_SITE=http://npm.taobao.org/mirrors/node-sass

“`

2. 使用命令:`npm config set sass_binary_site=
https://npm.taobao.org/mirrors/node-sass`,如果执行失败(一般是权限问题),就使用第一种方法。

3. 直接到官网(
github.com/sass/node-sass/releases/) 下载对应版本的node文件,如 v4.3.0 就下载 github.com/sass/node-sass/releases/tag/v4.3.0 选择对应系统的文件,然后直接用npm本地安装方式安装。

调整node版本

参考对应版本,如 v4.3.0 的release页面,看具体的node版本要求,重新安装node即可。

内容出处:,

声明:本网站所收集的部分公开资料来源于互联网,转载的目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。如果您发现网站上有侵犯您的知识产权的作品,请与我们取得联系,我们会及时修改或删除。文章链接:http://www.yixao.net/tech/29744.html

发表评论

登录后才能评论